Zope 3 Installation

The only dependency for Zope 3 istallation is Python 2.4. Zope 3 can be installed in all major platforms from source, also binary packages are available.

GNU/Linux

From Source

Download Zope 3.2 from http://dev.zope.org/Products/Zope3 Make sure you are installed Python 2.4.2 (or later).

To install (as root):

# tar zxvf Zope-3.2.0.tgz
# cd Zope-3.2.0
# ./configure --with-python=/path/to/python2.4
# make install

Replace /path/to/python2.4 with path to your Python interpreter. If you installed python using ./configure;make;make install most probably your path will be /usr/local/bin/python2.4 .

Binaries

FIXME: include major binary packges, Debian,RPMs?,*BSD packages.

Debian Etch or Ubuntu 6.04

In debian current testing (Etch) and ubuntu latest release:

# apt-get install zope3

Windows

From Source

FIXME: How to install the latest stable release (3.2) in Windows from source.

Binaries

First install Python 2.4.2 from here. Then download Zope setup